
Excel 2016:  
Creating, Using, and Modifying Pivot Tables 
Presented by Knack Training, LLC 

Topics Addressed: 

• Setting up data for successful use of Pivot Tables 

• Creating reports using sums, averages, and counts 

• Creating custom calculations 

• Using external data sources for your Pivot Table 

• Communicating relevant information effectively with data visualization 

• Using a Pivot Table for internal communications 
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Module 01: Core Skills 

Pivot Tables provide a huge amount of potential value; to get all the value possible from them, make sure that you use 

the essential framework successfully. In our first two lessons, we'll discuss how to structure the source data of a Pivot 

Table; then we'll use the next three lessons to build a Pivot Table that solves many problems. 

Exercise 01: Clean Data 

Open the first 
sheet of the 
workbook 

Open M01 Core Skills, and begin with L01 Clean 
Datasets.  

Try to use the 
dataset as a single 
unit 

Click within the Engagement Duration data region, 
and use the [CTRL] + [A] keyboard shortcut. 
 
You should recognize two important things about 
what happens: 

1. The two columns of Engagement Duration 
are selected, without the Client Details 
region. 

2. Engagement Duration – the label above the 
primary labels of Initial Contact and Contract 
Signed – is selected along with those labels. 

 

Change the 
connections 
between data 

Delete the blank columns – D, H, and K – and insert 
a blank row between 3 and 4. 
 
This created a relationship between the various 
columns, and focuses the labels on the primary 
labels above each column. 
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Reduce the visible 
spacing 

If you’d still like the headings Engagement Duration, 
Client Details, etc. to still appear connected to the 
relevant data, right-click and hide Row 4. 

 

Reduce 
inconsistencies 

In the Date column(s), make sure that all the entries 
are dates. In columns that are category-based (like 
Region), make sure that the categories are always 
consistently named. If your column has numbers, 
make sure all the entries are numbers. 

 

Make data useable In the Contract Duration column, use Text to 
Columns to split the number values from the 
abbreviation yrs. 

 

 

Before building a report in a Pivot Table, the data you’re working with should be consistent, contiguous, and calculable. 

For example, when we use Text to Columns on the Contract Duration column, we find that we can average the number 

of years each duration is. 
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Exercise 02: Working with Tables 

Find the sheet for 
table ranges. 

Select the tab L02 Using Table References. 

 

Attempt to create a 
Pivot Table 

On L02 Using Table References, select cell B6, and 
choose Insert Tab > Pivot Table. On the dialog that 
opens, notice the range reference. 

 

Cancel creating the 
Pivot Table 

Note that these cells are not flexible; if the original 
data added extra rows and columns, those would 
not be automatically added to the Pivot Table. Click 
Cancel. 

 

Convert the range 
into a Table 

Select cell B6, and click Insert Tab > Table. Notice 
that this, also, references the same set of cells. 

 

Name the Table You see the immediate formatting changes (color, 
alternating rows) and the filter drop-down arrows, 
but the most important element is on the Table 
Design Tab - the Table Name. 
 
Table names must (1) start with a letter - not a 
number or special character, and (2) have no spaces. 
In the near future, we'll see this name in action. Take 
a moment to name your table something different. 

 

Create a Pivot 
Table 

Select cell B6, and choose Insert Tab > Pivot Table. 
On the dialog that opens, notice the range 
reference. 

 

 

By using a Table, the range that is used in the Pivot Table is dynamic and named. This is critical for ease of maintenance. 
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Exercise 03: Creating a Simple Pivot Table 

Find the employee 
dataset 

Select the tab L03 Creating a Pivot Table. 
 

Identify a Pivot 
Table need 

In this list of employees, we might want to know the 
answer to: 
• What is the total salary by location? 
• What is the highest average salary by 

division? 
• What are the average salaries by level? 

  
In this situation, let's ask the question: How much 
are we paying employees (total) at each level? This 
might give us insight into whether we're overstaffed 
at higher levels, etc. 

 

Convert to a Table Once we know the question, it is a best practice to 
convert the dataset into a Table. So, click C5 and 
click Insert Tab > Table. 

 

Name the Table Give your Table a good name, like tblEmployees. 

 

Insert a Pivot Table Now, insert the Pivot Table by clicking cell C5 and 
choosing Insert Tab > Pivot Table. 
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Note the effects You have an empty Pivot Table on a new sheet 
(Sheet1). 

 
 

 

Add fields to create 
a summary report 

At this point, move into the Field List panel, and click 
the checkboxes for Division and Salary. Notice that 
these change the Pivot Table immediately. 
 

 

Note the effects This action - adding Categories like Location or 
Division to the Rows of a Pivot Table, and a Value 
like Salary to the Values of a Pivot Table - is the core 
of using Pivot Tables. You now have a simple report 
giving you insights about the divisions or locations 
that require the most salary. 

 

 

By using the Field List, we can create different summaries within a Pivot Table. 
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Exercise 04: Understanding Columns, Rows, and Values 

Find the next tab Select the L04 Columns Rows and Values sheet. 

 

Create a Table Click within the data set, and use [CTRL] + [T] to 
convert the data into a Table. 
  
In the Table Properties, name the Table 
something specific, like tblShipments.  

Insert a Pivot Table Click Insert Tab > Pivot Table. 

 
Create a Pivot Table on a new worksheet. 

 
 

 

Note your working 
data 

In the data, you'll notice that you have the 
following characteristics: 
• Both DATE SHIPPED and DATE ARRIVED 

are dates (of course), with the 
characteristics of having a year, month, 
and day value; 

• PROJECT SITE, PROJECT MANAGER, 
SHIPPING MANAGER, and MODE are all 
columns that have repeating values - we 
only have a few sites, a few managers, and 
a few shipping modes; and 

• SHIPMENT VOLUME, SHIPMENT WEIGHT, 
and SHIPPING COST are all numeric values, 
suitable to be added, averaged, etc. 
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Add relevant fields 
to the appropriate 
areas 

If we want to know the Total Cost broken down by 
Mode, we should be able to drag-and-drop the 
SHIPPING COST column into the Values box, and 
MODE into the Rows box. 

 
 

 

Make the 
breakdown more 
complex 

We can imagine, however, that air costs might be 
different, if we send the shipments to different 
locations. So, we can drag-and-drop PROJECT SITE 
into the Rows box, as well. 

 
 

 

Change the order This gives us Air broken down by Site, but we might 
drag-and-drop PROJECT SITE above MODE in the 
Rows field. 
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Split the two 
categorizations into 
different areas 

Drag-and-drop MODE to the Columns field. 

 

Calculate a count 
beside the sum 

Drag-and-drop a text value (like PROJECT 
MANAGER) into the Values field, and note how you 
can have both a Sum and a Count. 

 

Swap to a date 
breakdown 

Remove the Project Site and Mode entries from 
their Rows and Columns areas. 
 
Then, drag-and-drop the DATE SHIPPED into the 
Rows field.  

Note the grouping In modern versions of Excel, this automatically 
groups by the most logical segment – in this case, by 
month. 

 

 

The builder of a Pivot Table can put various fields into Rows, Columns, and Values. Placing numeric values into Values 

results in an automatic sum, while text values result in a count. Placing various grouping choices into Rows and Columns 

gives us a table with interesting breakdowns. 

Exercise 05: Calculations 

Find the next tab Select the L05 Calculations tab.  
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Add a Table and 
Pivot Table 

Click within the dataset, and choose Insert Tab > 
Table.  
 
Name the new Table tblProjectAnalysis. 
 
Click Insert Tab > Pivot Table, and place the Pivot 
Table on a New Worksheet.  

 

 

Break down the 
number of team 
members by 
Project 

Click the checkbox for PROJECT to place it in the 
Rows field. 
 
Click the checkbox for TEAM MEMBERS, and notice 
the value is placed in the Values field. 

 

Try another 
numeric column 

Click the checkbox for ACTUAL DURATION (days), 
and notice that it is placed in the Rows field. 
 
We recognize that due to the existence of N/A 
entries in this column, Excel doesn't see this as a 
numeric field. Additionally, if you drag ACTUAL 
DURATION (days) into the Values field, notice that it 
doesn't get added. 
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Hard-code the 
function to be used 

Using the drop-down arrow on Count of ACTUAL 
DU… to change the Value Field Settings… lets us get 
access to the Sum function, among others. 

 
 

 

Try different Count 
options 

At this point, let's look at the possible functionality 
for Actual Duration. The Count function is actually 
the same as COUNTA in a standard spreadsheet - it 
counts all the non-blank entries. 
  
Using Count Numbers, however, gives us the values 
that have been entered for ACTUAL DURATION. 

 

 

In a standard Pivot Table, non-numeric columns are automatically added to Rows, instead of Values. If we drag-and-drop 

a non-numeric column to Values, we see a Count function. We can change this to any function we like, but we should 

recognize there are non-numeric options in this column. 
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Module 02: Creating Perfect Pivot Tables 

Once the core tools in your Pivot Table are in hand, there are dozens of ways to shape the results. In this module, we'll 

look at formatting, filtering, and otherwise altering the Pivot Table. 

Exercise 01: Pivot Table Layouts 

Open the Module 2 
workbook 

Open M02 Perfect Pivots. Note the first tab, L01 
Layouts.  

Create a Pivot 
Table 

Convert the dataset on this page into a Table called 
tblShipments, and choose Insert Tab > Pivot Table. 
 
Finally, put Project Site and Shipping Cost into the 
Pivot Table. 

 

Experiment with 
Compact, Outline, 
and Tabular form 

Click Design Tab > Report Layout, and choose 
between these three options. 

 

Try again with 
another dimension 

Click the checkbox SHIPPING MANAGER, and notice 
that when you choose between Compact, Outline, 
and Tabular Form, they appear very different. 

 

Try repeating the 
item labels 

Click Design Tab > Report Layout, and try Repeat All 
Item Labels with these three layout choices. 
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Try this layout with 
consistent choices 

In this dataset, Project Site and Project Manager 
have a one-to-one relationship – there is a manager 
for each site. 
 
This means that if we put both Site and Manager 
into the Rows field, we get something like this: 

 

Change the 
configuration for a 
one-to-one 
relationship 

Clicking Design Tab > Subtotals, we can choose Do 
Not Show Subtotals. 
 
Clicking Design Tab, you can disable the Row 
Headers checkbox. 
 
Clicking the Analyze Tab, you can turn off the +/- 
button. 

 
 

 
 

 

Notice the effects 
of these choices 

By changing these values, we’ve made the table 
appear as if it treats the Site and Manager as two 
entries for the same record. 

 

 

In a Pivot Table, the Compact form that is the default is good for showing subordinate relationships. However, it makes 

the display of additional data less clear. So, changing the Layout configurations can have positive results. 
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Exercise 02: Aesthetic Formatting Choices 

Find the Aesthetics 
tab. 

Select the tab for L02 Aesthetic Formatting. 
 
Note that the data has already been made into a 
Table; the Table has been named 
tblEmploymentData; the Table has been set to a 
black-and-grey color scheme with banded rows. 

 

Create a Pivot 
Table alongside the 
Table 

Select cell C9, and choose Insert Tab > Pivot Table. 
 
Choose for the location Existing Sheet, and click cell 
K3 on that sheet. 

 

Add the relevant 
fields to the Pivot 
Table 

Click the checkboxes for DIVISION, LOCATION, and 
SALARY. This will create a Pivot Table with a 
calculation, and a two-level breakdown between 
Division and Location. 
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Change the number 
formatting 

By clicking Sum of Salary > Value Field Settings, you 
can get the dialog to open for the calculation and 
other options. 

 
 

 

Make three 
changes to Value 
Field Settings 

First, choose Average as your calculation. 
 
Then, type the Custom Name Avg Salary. 
 
Finally, click the Number Format button, and choose 
an Accounting format for the numbers that doesn’t 
include decimal places. 

 
 

 

Note the simplicity 
of the display 

After you click OK twice, notice that the numbers 
display nicely, and the label is cleaner, as well. 

 

Collapse the 
categories 

Click Analyze Tab > Collapse Field, and you will see 
only the Divisions, with the Locations folded under. 
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Change the color 
scheme 

On the Design Tab, look through the Pivot Table 
Styles and choose a more black-and-white look. 

 

Expand-and-
contract the 
Divisions 

As you click the + buttons to expand each Division, 
note the similarity to the original table. 

 
 
 

Customize further On the Design Tab, click the checkbox for Banded 
Rows. 

 

Customize further Right-click the Style you chose, and select Duplicate 
from the context menu. 

 

Stripe the rows 
consistently 

To match the existing Table, we can choose First 
Row Stripe, and Format; then Second Row Stripe, 
and Format. We can then match the background 
colors of the two stripes in our Table. 
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Choose our new 
Style 

Finally, click the Pivot Table Styles drop-down, and 
choose the new Style. 

 

 

With a combination of layout, Style, and number formatting, we can create a Pivot Table that looks exactly the way we 

like. 

Exercise 03: Sorting 

Find the worksheet Select the L03 Sorting tab. 

 

Create a simple 
Pivot Table 

Using the table tblContracts, break down the Total 
Lifetime Value by Region. 

 

Sort by Row Labels Click the drop-down arrow at the head of the Row 
Labels area, and choose either Sort Ascending or 
Sort Descending (Ascending was already chosen by 
default). 
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Sort by the numeric 
values 

Click within the calculated range of the Pivot Table 
(any number under Total Lifetime Value). 
 
Then, click Data Tab > Sort A-Z or Sort Z-A. 

 
 

 
 

 

Manually sort the 
regions 

Another option is to click-and-drag items around. In 
this example, you may want to always see Eastern, 
Pacific, Europe, and Ex-US NA in that order. Click 
and drag each of those items to the right place 
relative to one another. 
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Sort within 
groupings 

To make the Pivot Table more complex, click the 
checkbox for Client Type, nesting these under the 
various regions. 
 
Click onto any of the fields – one of the Regions, one 
of the Client Types, or one of the number values – 
and sort by clicking Data > Sort A-Z or Sort Z-A. 

 

 

Sorting can happen based on alphanumeric order on any of the fields, or it can be a manual process, allowing you to 

bring a specific value to the top. 

Exercise 04: In-Table Filtering 

Find the filtering 
sheet 

Select the tab L04 In-Table Filtering. 
 

Create a simple 
Pivot Table 

From tblTickets, create a Pivot Table that uses 
Representative for the Rows Field, and drag Ticket 
ID to the Values Field. This will create a Count of all 
the tickets. 

 
 

 

Filter using Row 
Labels 

Click the Row Labels drop-down, and filter by the 
Representative. 
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Filter by the Cell 
Values 

Click the Row Labels drop-down, and choose Value 
Filters. Click the option for Greater Than... 

 

Choose a lower 
limit 

Type 50 into the Value Filter, and see that you only 
see numbers of tickets over 50.  

Explore the data 
more closely 

Find any number value in the Pivot Table, and 
double-click the number. You’ll find a new data set 
generated from this request. 

 

Use the Filter Field Clear the previous filters on the Pivot Table. Now, 
drag Product to the Filters field. 

 

Filter by a single 
value 

Using the Product drop-down menu above the Pivot 
Table, choose one of the Products. 

 

Clear the filter Return to All in this drop-down menu  

Filter by multiple 
items 

On the Product drop-down menu, choose Select 
Multiple Items, and choose which items to show in 
your Pivot Table. 

 

Create multiple 
reports 

Clear your filter by re-checking the All option on 
your drop-down. 
 
Because Product is in the Filters Field, you can now 
click Analyze Tab > Options Drop-Down > Show 
Report Filter Pages...  
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Watch the pages 
generated 

Now that you’ve chosen to show the broken-out 
report filter pages for each Product, you have tabs 
named after each item. 

 

 

On-report filtering can be done through the Rows or Values, and also by using the standard Filters field of the Pivot 

Table. However, modern filters are through Slicers and Timelines. 

Exercise 05: Slicers and Timelines 

Find the next tab 
for filtering 

Select the tab L05 Slicers and Timelines. 
 

Create a Pivot 
Table from the data 

From the table tblEmployeeList, create a Pivot Table 
that calculates Total Salary by Division. 

 

Add Slicers Selected on the Pivot Table, click Analyze Tab > 
Insert Slicer. Then, click the checkboxes for Location 
and Level. 
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Add a Timeline Selected on the Pivot Table, click Analyze Tab > 
Insert Timeline. Then, click the checkbox for Date of 
Hire. 

 
 

 

Arrange the filters Notice that now you can not only click-and-drag to 
move and resize the windows, but you can also click 
on any Slicer, then choose Slicer Tab > Columns to 
make the Slicer have 2 or 3 (or more) columns. 

 

Use the various 
filters 

You can either single-click an entry, Shift-Click many 
entries (for a range of entries), or Ctrl-Click many 
entries (for many disconnected selections). 

 

Adjust the Timeline On the Timeline, you can choose Years as your 
Period, and filter by Years, rather than Months. 

 
 

 

 

Filtering on the Slicer and/or Timeline for a Pivot Table is a good way to have beautiful, dynamic filtering that is user-

friendly. 

Exercise 06: Grouping 

Find the Grouping 
tab 

Select the tab L06 Grouping. 
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Create a Pivot 
Table from the 
Table 

Using tblShipments, create a Pivot Table that 
calculates Total Shipping Costs with no 
segmentation.  

Segment by date Click-and-drag Date Shipped into the Rows field, 
and notice that those dates are automatically 
grouped together. 

 
 

 

Change automatic 
grouping 

Right-click the labels (the month abbreviations), and 
choose Group... to change the settings to Quarter. 
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Change the Row 
Labels 

Remove Date Shipped from the Rows field. Instead, 
drag-and-drop Shipment Volume to the Rows field. 

 
 

 

Group these values Excel doesn’t immediately group these, as it did with 
dates. So, right-click the Row Labels and choose 
Group... 

 

Change the 
automatic grouping 

Excel decides to set the current maximum and 
minimum as the Starting at and Ending at values, 
and provides a simple grouping number. Change 
these to: 
 
0 
250 
50 
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See the impact Now, your Pivot Table is prepared for Shipping 
Volumes up to 250 cubic meters, and will only 
concern itself with the groupings every 50 cubic 
meters. 

 

 

Grouping number values allows you to see relationships where there typically aren’t any.  
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Module 03: Data Handling 

Pivot Tables analyze data, so in this module we’ll take a closer look at the data we’re bringing into the Pivot.  

Exercise 01: Changing and Refreshing Data 

Open the Module 3 
workbook 

Open M03 Data Handling, and access L01 Refreshing 
Data.  

Create three tables Notice that on this tab we have three lists of tasks. 
Imagine that each list represents the project tracking 
information for a different week. 
 
Click on the first list, and turn it into a table called 
tblTasksWk15, then create tables called 
tblTasksWk16 and tblTasksWk17. 

 
 

 

Create a Pivot 
Table from the 
Week 15 data 

Click on cell B5, and choose Insert Tab > Pivot Table. 

 

Break down the 
data 

In the Pivot Table, create Total Hours by 
Department. 

 

Update the current 
dataset 

Return to tblTasksWk15, and add Task 22 for 
HUMAN RESOURCES, Project ACADIA. This should 
take 45 hours. 
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Refresh the Pivot 
Table 

Prior to refreshing, note that your Pivot Table says 
Human Resources had 182 hours spent on these 
projects. Click Analyze Tab > Refresh, and watch the 
value climb to 227. 

 
 

 

Update the report Selected on the Pivot Table (cell A4, for example), 
click Analyze Tab > Change Data Source. 

 

Change to Week 16 Change the table name to tblTasksWk16, and watch 
your report update to match this new data set. 

 

 

A Pivot Table can always be updated as the data changes; doing this with Tables makes the update easier to maintain. 

Exercise 02: External Data 

Find the report 
page and external 
data 

Select the tab for L02 External Data, and also open 
M03 External Data.  

 

 

Create a Pivot 
Table from External 
Data 

In M03 Data Handling, click Insert Tab > Pivot Table. 
Choose Use an external data source. 

 

Find the external 
table 

Click Choose Connection..., and find the Table from 
our second spreadsheet. 
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Complete your 
Pivot Table 

Click OK, and create a Pivot Table that pulls data 
from another spreadsheet. 

 

 

The tool we used in this exercise has been around a very long time, and simply pulls the data from a table outside the 

current spreadsheet, if it is open to be pulled. Power Query, however, is a more sophisticated tool for solving the same 

problem. 

Exercise 03: Introduction to Power Query 

Find the Power 
Query tab 

Select the tab L03 Power Query Intro. 

 

Query the outside 
data source 

Rather than our previous example, where the table 
was available on an open file, we can click Data Tab 
> Get Data > Launch Power Query Editor to access 
data across dozens of sources. 
 
Launch the Power Query Editor to query an Excel 
spreadsheet, CSV file, database, or even website 
(we’ll be using the same M03 External Data 
spreadsheet from the previous example). 
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Get data from a 
Source 

Click Home Tab > New Source > File > Excel. 

 

Identify the 
spreadsheet 

Navigate to the M03 External Data file. 

 

Identify the data 
set 

Choose the table tblSales2017to2019. 
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Modify the query Click the 123 button for SALE DATE, and convert the 
column to a Date. 
 
Click the Sale Price Column, hold [SHIFT] and click 
the COGS Column. Now, click Add Column > 
Standard > Subtract. 
 
Notice that a new column that can be called Profit is 
created. 
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Load the query to a 
Pivot Table 

Click Home > Close & Load > Close & Load To... 

 

Choose the proper 
location 

Choose the radio button for PivotTable Report, and 
specify an Existing Worksheet location on L03 
Power Query Intro. 

 

Use the 
modifications to 
the data 

Create a Pivot Table that calculates Total Profit (a 
value that Power Query created), broken down by 
Region. 

 

 

Power Query creates a dynamic connection to outside data sets (Excel files, and many other sources), and allows you to 

transform the data with formatting, calculations, and other steps. Finally, this can be loaded directly into a Pivot Table. 

Exercise 04: Understanding the Excel Data Model 

Find the Data 
Model sheet 

Select the tab L04 The Excel Data Model. 

 

Identify the 
situation 

In this data set, we recognize that there are 
different types of projects. We should try to avoid 
repeating ourselves, so instead of putting Open 
Ocean or Coastal Waters next to each project in 
the larger list, we create a smaller list to map each 
project to a project type. 
 
We decide to avoid combining these lists, if we 
can simply establish a relationship. 
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Convert lists into 
tables 

Click cell B5, and convert the Shipment list into a 
Table called tblShipments. Click cell O5, and 
convert the Project Type list into a Table called 
tblProjectTypes. 

 
 

 

Create a Pivot 
Table that adds to 
the Excel Data 
Model 

Click on tblShipments, and create a Pivot Table. 
Stop before clicking OK to see the checkbox Add 
this data to the Data Model 
 
Click the checkbox to add the current Table to the 
Data Model. 

 

Total the Shipping 
Costs 

Click the checkbox for Shipping Cost, to add that 
to the Values field. However, don’t add anything 
to the Rows field. 

 

Search all the 
Tables 

Notice that at the top of the PivotTable Fields 
panel, there is now an option to choose between 
Active and All. Choose All. 

 

Find the Project 
Type field 

Expand tblProjectTypes, and click the checkbox 
for Project Type. 
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Create a 
Relationship 

Notice that the Pivot Table is broken (the same 
value is repeated multiple times), and there is a 
yellow bar on the right side of the screen. This is 
because we haven’t established the relationship 
between tblShipments and tblProjectTypes. Click 
CREATE to change this. 

 
 

 

Identify the 
matching columns 

In the first set of drop-downs, tell Excel that we 
have tblShipments with a column called PROJECT 
SITE.  
 
In the second set of drop-downs, tell Excel that 
tblProjectTypes also has a column called PROJECT 
SITE. 

 

See the changes You may have to click Analyze > Refresh to see 
the numbers change, but the Pivot Table will now 
break down the Shipping Costs by Project Type, 
which are in two different tables. 

 

 

The Excel Data Model establishes that different tables in the file can have relationships with one another, that can be 

used in building Pivot Tables. 
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Module 04: Advanced Calculations 

Beyond the straightforward sums and counts you typically generate in the calculation area of a Pivot Table, you can 

create a number of interesting insights from calculated fields, items, and other tools. 

Exercise 01: Running Totals 

Open the Module 4 
Workbook 

Open M04 Advanced Calculations, and begin with 
L01 Running Totals.  

Add a Pivot Table From tblExpenses, create a Pivot Table for Total 
Transaction Value by Department. 

 

Sort by the values Click within the Total Transaction Value column, and 
Sort descending (largest on top). 

 

Add the Running 
Total 

Drag-and-drop the Transaction Value column into 
the Values field again. 

 

Change the 
presentation 

Click the drop-down arrow for the Transaction 
Value, and change the Value Field Settings. 
 
Choose the tab Show Values As. 

 
 

 



Microsoft Excel: Working with Pivot Tables 

 P a g e  | 35 

Running Total Choose Running Total In and the Base field 
Department. 
 
Format the numbers as you like, and see the 
resulting setup. 

 
 

 

 

By changing to Running Total In Department, we get the same final value ($315K), but we show it in two different 

presentations. 

Exercise 02: Difference Functions 

Find the Ticket 
tracker. 

Select the tab for L02 Difference Functions. 
 

Create a count of 
each product’s 
tickets 

Select the table tblTickets, and create a Pivot Table 
that counts the tickets, broken down by Product. 

 

Sort the Pivot Table Sort Descending (high to low) by the number of 
tickets. 
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Add another count Drag-and-drop one of the fields into the Values field, 
and create another count. 

 

Change the 
presentation of the 
second count 

Click the Values drop-down menu and change the 
Value Field Settings 

 

Switch to a 
different 
calculation 

On the Show Values As tab, change to % Difference 
From, and choose Empower. This will set Empower 
(the highest value) as the 100%, and the rest will 
show up below that. 

 

See the changes 

 

 

 

This concept is to set a value, and demonstrate the difference from that value – whether percentages or whole 

numbers. 

Exercise 03: Calculated Fields 

Find the Calculated 
Field tab 

Select the tab L03 Calculated Fields. 
 

Identify an 
uncalculated bit of 
information 

In our sales data on this table, we have COGS and 
Sale Price, and the difference between these 
represents the Profit. We could calculate this in the 
data, or in the Pivot Table. 
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Create a Pivot 
Table 

Create a Pivot Table using tblSales2017to2019, 
breaking the sales down by Client Type. Don’t insert 
any numbers to be calculated at this time. 

 

Add a Calculated 
Field 

Click Analyze Tab > Fields, Items, & Sets > 
Calculated Field. 

 

Create the field Name the field Profit, and make it  
 
= ‘SALE PRICE’ – COGS 

 

 

A Calculated Field is the equivalent of having another column on your data set. Sometimes you can’t alter the existing 

data, so creating a calculated field from the other fields can be helpful. 

Exercise 04: Calculated Items 

Find the Calculated 
Items sheet. 

Select the tab for L04 Calculated Items. 
 

Create a Pivot 
Table 

On tblInventory, create a Pivot Table that totals 
Quantity by Product. 

 

Assume 
categorization 

Let’s say that we know Brightburn, Hummingbird, 
and Road Flare are Optical products, and Greylock is 
Software. 
 
Click somewhere within the Row Labels area, to 
inform Excel you want to change the Row Labels. 
 
Click Analyze Tab > Fields, Items, & Sets > 
Calculated Item.. 
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Create a new item Name the Item Optical, and set it equal to 
=Brightburn + Hummingbird + ‘Road Flare. 

 

Filter out the 
repeated elements 

Now that Optical is added to the Pivot Table, click 
the Drop-down arrow for Row Labels, and remove 
Brightburn, Hummingbird, and Road Flare. 

 
 

 

View the result Now, we’ve grouped together three items into a 
single item – much like we could do with the Excel 
Data Model if we have these categorizations. 

 

 

Calculated Fields are the same as new columns. Calculated Items are the same as new categories. 

Exercise 05: Using Pivot Tables as a Reference 

Find the reference 
tab 

Select the tab L05 Referencing Pivot Tables. 
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Find the two values 
we need for our 
calculation 

On this sheet, we see two Pivot Tables, filtered by 
Slicers, that will fluctuate as we adjust the visual 
filters. We’d like the number values from these Pivot 
Tables to be used to calculate the Percent of Total 
Revenue during any period. 

 

Reference the first 
value 

In cell H21, enter an =, then click the cell with the US 
GOVT Revenue (H8).  

Reference the 
second value 

In cell H22, enter an =, then click the cell with Total 
Revenue (G4).  

Use these values In cell H24, enter the formula =H21/H22 to calculate 
the Percentage of Revenue. 

 

Adjust the 
calculation with the 
Slicers 

By clicking different Fiscal Years and different 
Quarters, see that the calculations adjust. 

 

 

Whether by using the GETPIVOTDATA function or a cell reference, we can pull a numeric value from a Pivot Table, then 

use it in other calculations. Because the Pivot Table is controlled by Slicers, so to is our calculation. 
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Module 05: Data Visualization 

A Pivot Chart is effectively just a chart based on a Pivot Table, so there are a number of customizations that we can 

perform on them to make beautiful, effective communication pieces. 

Exercise 01: Creating a Pivot Chart 

Open the first tab 
of the Data 
Visualization 
workbook 

Open M05 Data Visualization, and begin with L01 
Creating a Pivot Chart  

Find the Pivot Table In cells N3:O9, you’ll find an already-created Pivot 
Table. 

 

Add a Pivot Chart At this point, click on the Pivot Table, and choose 
Analyze > Pivot Chart. 

 

Choose an 
appropriate chart 

Click on Clustered Column and click OK. 

 

Change the labeling 
on the Pivot Chart 

To remove the Total Lifetime Value and Client Type 
markers, press Analyze > Field Buttons. 
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Filter the chart Click Analyze > Insert Slicer, and add a slicer to the 
Region information. 

 

Slice the chart As you choose different regions, both the table and 
the chart fluctuate. 

 

 

A Pivot Chart is a 1:1 reflection of the contents of the Pivot Table. As the Pivot Table is filtered, so too will the Pivot 

Chart. 

Exercise 02: Customizing a Pivot Chart 

Find the next tab. Select the tab for L02 Custom Pivot Charts. 

 

Add a chart to the 
existing Pivot Table. 

Click cell L3, and choose Analyze > Pivot Chart. 
 
Select a Clustered Bar Chart. 

 

Remove 
unnecessary 
labeling 

Click Analyze > Field Buttons to disable the field 
buttons. 
 
Click and delete the Total entries in the Title and 
Legend. 
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Note that bar 
charts are flipped 

Because of the location of the two axes, Corporate 
and Production are flipped between the chart and 
the table. Click on the labels of your Bar Chart. 

 

Access the Chart 
Formatting Tools 

Use the shortcut [CTRL] + [1] to change the order of 
these labels. 

 
 

 

Continue to 
remove 
unnecessary visuals  

Delete the Axis labels, and remove the lines from the 
chart. 
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Line up the bars Now, by resizing and moving the chart, you can see it 
matched up with the Pivot Table nicely. 

 

 

While Pivot Tables may look a bit clunky when they first come onto a page, you can clean them up and make them very 

pleasant to interact with. 

Exercise 03: Creating Dashboards 

Find the Dashboard 
tab 

Select the tab L03 Dashboards. 
 

Add another Pivot 
Table and Chart 

Note that we have a Total Salary by Division Pivot 
Table and Pivot Chart. 
 
Below this combination, add a Pivot Table and Pivot 
Chart representing Avg Salary by Level. 

 

Add a Slicer for 
Location 

Click onto one of the two Pivot Tables, and choose 
Analyze > Insert Slicer. Click the checkbox for 
Location. 

 

Connect the Slicer 
to the other Pivot 
Table 

Click on the Slicer, and choose Slicer > Report 
Connections. 
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Choose the other 
Pivot Table 

At this point, there should be two Pivot Tables listed 
on this page. Make sure that both checkboxes are 
marked. 

 

View the impact of 
the Slicer on both 
Pivots 

Click the options on the Slicer, and watch as both 
Pivot Tables are filtered simultaneously. 

 

 

As many Pivot Tables and Pivot Charts as you like can be filtered by the same Slicer. 

Exercise 04: Custom Labeling 

Find the donut 
chart tab 

Select the tab L04 Custom Labeling. 
 

Identify the data 
visualization 
benefit 

In the donut chart in columns O:P, we see that a 
large label, stating the percentage of our total 
volume was conducted by truck, would be a good 
visualization element to have in the middle of the 
donut. 
 
Rather than using the built-in data label tool, we’ll 
use a linked textbox. 

 

Insert a textbox Click cell Q1 (outside the chart and Pivot Table), and 
choose Insert Tab > Text Box. 

 

Draw the textbox Click-and-Drag a box on the spreadsheet. 
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Connect the 
textbox to the 
value 

Don’t type anything directly into the text box. 
Instead, click in the Formula Bar at the top of the 
screen, and reference the cell from the Pivot Table. 
Now, when you press [ENTER], you’ll see the value 
show up dynamically. 

 
 

 

Customize the text 
box 

Resize, change the font, and otherwise make the 
text box appropriate to your needs. 

 

 

While every chart can use data labels, sometimes placing a larger label on your chart, wherever and however you need 

it, is more useful. In this exercise, we linked our text box to a cell in the spreadsheet, and it will dynamically update 

whenever the data or the filter changes. 
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Module 06: Advanced Pivot Table Techniques 

This is the wrap-up module for the course – everything we can think of, in one place! 

Exercise 01: Refreshing Data 

Open the final 
workbook 

Open M06 Advanced Options, and start with L01 
Automatic Refreshing.  

Change the Pivot 
Table contents 

Change a value in one of the two Tables on this page 
– either to a number value for expenses, or to the 
name of one of the Approvers. 

 
 

 

Notice that the 
Pivot Table does 
not change 

The Pivot Table is accessing information from these 
Tables, but does not automatically update.  

 

Record a Refresh 
All 

Click on the Pivot Table, and click Developer Tab > 
Record Macro. Save the macro to your Personal 
Macro Workbook. 

 
 

 

Refresh all the 
Pivot Tables 

Click Analyze Tab > Refresh > Refresh All.. 

 

Stop recording Click Developer Tab > Stop Recording. You now have 
a macro that refreshes all connections in your 
workbook. 
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Add a Refresh 
Button 

There are many ways to execute this macro, but 
we’ll click Developer Tab > Insert > Button. 
 
Then, simply assign the macro we recorded 
(RefreshAllPivotTables) to the button press. 

 
 

 

Make a change and 
press the button 

Change some part of the data going into your Pivot 
Table, and press the refresh button. 

 

 

Pivot Tables, Power Query, and a few other tools, require connections to data. That data connection needs to be 

refreshed, and the button press of Refresh All automatically refreshes everything that needs it in your workbook. 

Exercise 02: Preflighting a Pivot 

Find the two 
Preflight tabs. 

Note the contents of L02 Preflight and L02 REPORT. 

 

Consider the best 
end-user scenario 

The end user would like to see the reporting as 
clearly as possible, with as little unnecessary 
navigation as possible. For this reason, we’ll be 
‘cleaning up’ our work. 

 

Hide the data tab Right-click the tab L02 Preflight, and choose Hide. 
Now the end user will only be concerned with the 
Report tab. 

 

Hide the 
unnecessary Pivot 
Tables 

Select columns A:D on L02 REPORT, then right-click 
and choose Hide. Now, only the Pivot Charts and 
Timeline are visible. 
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Snap the charts to 
the Grid 

Clicking on each chart’s corners, [ALT] + [CLICK] + 
[DRAG] these corners toward the Gridlines on the 
page, and the charts will snap directly to those lines. 

 

Hide the Gridlines Click View Tab > Gridlines to hide gridlines. 

 

Hide the 
unnecessary 
elements from the 
charts 

By clicking the Field Buttons button, you can turn off 
the grey boxes on each chart. 
 
By clicking on unnecessary elements and pressing 
[DELETE], we remove those elements. 

 

Use the cell widths 
to stretch the 
charts 

Now that each chart is snapped to the grid, clicking-
and-dragging the borders between cells will make 
the charts the correct size. 

 

 

 

Preflighting your workbook means preparing it for interaction with others. By hiding the core data and only providing 

chart interaction, you simplify the work for others. By removing visual clutter and snapping the elements to the same 

grid, you bring a simplicity to the visual space that users will engage with. 
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Exercise 03: Custom Number Formatting 

Find the Custom 
Number Formatting 
Pivo Table 

Select the tab L03 Number Formatting. Note the 
Pivot Table already built there. 
 
Our goal is to make this as readable as possible. 

 

Select the numeric 
cells 

Highlight all the cells that have the salary numbers. 
Note that all salary numbers begin in the millions. 

 

Change the number 
formatting 

Click Home > Number Formatting > Pop-Out Button. 

 

Choose custom Click the Custom entry, and type the following: 
 
$ 0.0,, “M” 
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Watch the 
application 

By changing the number formatting on these cells to 
a custom setting, we can present these rather large 
numbers as smaller, easier-to-consume 
representations. 

 

 

Number formatting takes a numeric input and presents it in varied ways. This allows us to get interesting date, number, 

time, and currency representations. 

Exercise 04: Conditional Formatting 

Find the final tab Select the tab L04 Conditional Formatting. Find the 
Pivot Table on the page. 

 

Highlight the 
numeric cells 

Excluding the Grand Total, select all the number 
cells. 

 

Turn on Conditional 
Formatting 

Click Home Tab > Conditional Formatting > Color 
Scales, and choose the Red-Green color scale. 
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View the impact of 
your choice 

By adding color-coding to the cells in our Pivot Table, 
we are able to more quickly find the relevant 
information. 

 

 

Pivot Tables by themselves are powerful analysis and visualization tools. However, combined with color-coding, custom 

number formatting, and other tools like Power Query, they become part of an incredibly robust analysis suite. 

 

 


